Back to overview
Downtime
Devrev is down
Sep 23, 2024 at 5:59am UTC
Resolved
Sep 23, 2024 at 6:02am UTC
Status is mitigated, thanks for the patience
Affected services
Updated
Sep 23, 2024 at 6:01am UTC
Working on it, please bear with us
Affected services
Created
Sep 23, 2024 at 5:59am UTC
Auth0 is acting weird
Affected services